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Chapter -1 : 

The computer system 

Meaning of computer  

A computer is an electronic machine which is made up of various 
devices that help you to enter the data ( input) through keyboard a 
mouse process it using the CPU and give the result (output) which can 
be seen on the monitor or printer. 

A computer works in the IPO cycle- Input process output. 

Input – The data and instrucƟons we give to the computer is called as 
input. The device that is used to send input to the computer is an input 
device. 

Eg- keyboard mouse and scanner  

 

 

 

Process- The computer takes acƟon on the data entered bt the user. It 
converts the data into meaningful informaƟon with the help of the 



processor which is the CPU. This conversion of data into informaƟon is 
called processing. CPU has three parts-  

ALU (ArithmeƟc logic unit)- the ALU does arithmeƟc calculaƟons like 
addiƟon, subtracƟon, mulƟplicaƟon and division and so on.  

MU( Memory Unit)- The MU stores data and instrucƟons given to the 
computer and the result of the processing. 

CU (Control Unit)- The CU coordinates between all the parts of the CPU  

Output- The result which we get aŌer processing the data and 
instrucƟons is called output. The output which is displayed on the 
screen of the monitor is called the soŌ copy. The printout of the soŌ 
copy on paper is called the hard copy. 

Eg- monitor, printer, speaker etc. 

Storage- when you have finished working with your data you can store 
it in a more permanent form call storage hard disk, DVD, pendrive etc 

are storage devices. 

 

Features of a computer- 

1. Computer works at a very high speed it does calculaƟon faster 
than a human being . 



2. Computer always gives accurate results so whatever input we give 
it gives accurate results.  

3. Computer is free from Ɵredness unlike human beings it can work 
with same efficiency for a long Ɵme. 

4.  The best thing about a computer is its large memory but it stores 
a huge amount of informaƟon that can be retrieved quickly and 
easily when needed.  

5. A computer is a mulƟpurpose machine that performs a variety of 
task and is used in almost all fields.  

Types of computers- 

1. Microcomputers- these computers are made to be used by one 
person at a Ɵme desktop laptop tablet and smartphone are called 
microcomputers.  

2. Minicomputers- this computers are small general purpose 
computers having the capability to serve number of users 
simultaneously  

3. Mainframe computers - this computers are very large past and 
power computer some mainframe computers are so big that they 
require as much large space as that of a room.  

4. Supercomputers - these are the largest and fastest of all types of 
computers they can process very large amount of data quickly 
they are used in very big organisaƟon and government 
departments to do task such as weather forecasƟng in rocket 
launching PARAM was India's first supercomputer developed in 
1991. 

 

Book exercises. 



A. Tick the correct opƟon. 
1. Which of the following can do all arithmeƟc calculaƟons?-ALU 

a.CU.       b. ALU.     c MU 
 

   2. Which of the following is known as India’s first supercomputer?- 
PARAM 

a.Pratyush. b.PARAM c. Server 
3. A computer gives ____ results.- accurate 
a false.  b.incorrect.  c.accurate 
4.The data or instrucƟons we give to the computer is called –input 
a.input.  b.output.  c.storage 
 
 

B. Fill in the blanks . 

( Hard copy, micro, informaƟon, CU, CPU ) 

1. Desktop, laptop, and tablet computers are ________ computers. 

2. The ________ coordinates between all the parts of the CPU. 

3. The memory of the _______ stores data and instrucƟons. 

4. The meaningful and organized form of data is called _______. 

5. A printout of the soŌ copy on paper is called the ________ of the 
output. 

 

 

C. Write true or false. 



1. The computer is a mulƟpurpose machine. -TRUE 

2. The working speed of a computer is very slow.- FALSE 

3.ALU does all the processing.-FALSE 

4. The output which is displayed on the screen of a monitor is called the 
hard copy.FALSE 

5. Storage is the result we get aŌer processing.- FALSE 

 

 

 

D. Answer in short. 

1. What are the three parts of the central processing unit? 

2. Name any two storage devices. 

E. Answer in detail. 

1. What is meant by input and output? 

2. Name any three features of a computer. 

3. What is supercomputer? 

 

 

 

  



 

Chapter -2: 

Computer Hardware and SoŌware 

 

A computer consists of two components 

 – hardware and soŌware  

 

Hardware – The parts of the computer that we can touch is called 
hardware. All the input, processing, output and storage devices such as 
keyboard,mouse, monitor, speakers,printers, scanner,pendrive, DVD are 
hardware parts of a computer. 

SoŌware – computer hardware cannot work by itself. It needs step by 
step instrucƟons to perform a task. These step wise instrucƟons are 
called soŌware or programs. A soŌware helps us to give input to the 
computer Hardware. It also helps the computer to process input and 
convert it into output. 

Types of soŌware  

There are mainly two types of soŌware –  

1. System soŌware  
2. ApplicaƟon soŌware  

System soŌware – System soŌware controls and manages the overall 
acƟviƟes of a computer system. The system soŌware is like a manager 
of a computer system. 



OperaƟng system is an example of system soŌware. 

ApplicaƟon soŌware – ApplicaƟon soŌware helps us to perform a 
specific type of job. For example you draw and color pictures in tux 
paint SoŌware, but you cannot play a movie or a song in it . 

Tux paint and rhythm box are examples of applicaƟon soŌware.  

GIMP is used for creaƟng and ediƟng photos and designs. 

******************** 

 

Book exercise. 

A. Tick the correct opƟon 
1. Which of the following is not a hardware part of a computer?- TUX 
PAINT 
a.Speakers.  b.DVD.    c.Tux Paint 
2. Which of the following is a system soŌware?- LINUX 
a.Impress   b.Tux Paint. c.Linux 
3. Which of the following is a soŌware?- GIMP 
a.Mouse.  b.CPU.  c.GIMP 
4. The stepwise instrucƟons are called –- PROGRAMS 
a.Programs. b.Hardware. c.Computer 
 
B. Fill in the blanks. 
( Two, soŌware, system, applicaƟon, operaƟng) 
1. A computer consists of _______ components. 
2. The programs that instruct the computer to do different things are 
called ________ 



3. ________ soŌware controls and manages the overall acƟviƟes of a 
computer system. 
4. ________ soŌware is designed to perform one or more specific 
type of jobs on a computer. 
5. ________ system runs applicaƟon soŌware. 

 

C. Answer in short. 
1. Give one example of system soŌware. 
2. Name the applicaƟon soŌware which is used for creaƟng and 
ediƟng photos. 

 

D. Answer in detail. 
1. Define hardware and give any two examples 
2. Define soŌware and given an example. 
3. Which is an applicaƟon soŌware? Give one example. 

 

E. Rearrange the leƩers to get correct words. 
1. RARHDWEA- HARDWARE 
2. EYETMS OSATWREF- SYSTEM SOFTWARE 
3. IMPRESS- IMPRESS 
4. LIUNX- LINUX 
5. SNCANER- SCANNER 

  



 

 

CHAPTER – 3 

INTRODUCTION TO LINUX 

What is Linux? 

- Linux is an open-source operaƟng system (OS) that is widely used in servers, 
supercomputers, and embedded devices. 

- It was created by Linus Torvalds in 1991. 

History of Linux 

- Linux was iniƟally developed as a Unix-like OS for personal computers. 

- It was first released in 1991 and gained popularity in the late 1990s. 

Features of Linux 

- Open-source and free to use. 

- Highly customizable and flexible. 

- Secure and stable. 

- Supports mulƟple file systems and hardware plaƞorms. 

 Linux DistribuƟons 

- A Linux distribuƟon (distro) is a version of Linux that is packaged with other 
soŌware and tools. 

- Popular Linux distros include Ubuntu, Debian, Fedora, and CentOS. 



 

 

What is Ubuntu Desktop? 

Ubuntu Desktop is a special kind of computer program that helps us use our 
computer. It's like a magic window that shows us lots of things we can do on our 
computer.  

 

What are the different parts of Ubuntu Desktop? 

1. Desktop: This is the main area where we can see all our files, folders, and 
pictures. 

2. Icons: These are liƩle pictures on our desktop that help us open different 
programs, like games or painƟng tools. 

3. Toolbar: This is the bar at the top of our screen that shows us important 
informaƟon, like the Ɵme and our computer's name. 

4. Files and Folders: These are like our computer's filing cabinet, where we can 
store all our documents, pictures, and videos. 



 

What can we do on Ubuntu Desktop? 

1. Play Games: We can play lots of fun games on our computer, like puzzles, racing 
games, and more! 

2. Paint and Draw: We can use special programs to paint and draw pictures on our 
computer. 

3. Write Stories: We can use our computer to write stories, leƩers, and even 
emails to our friends! 

4. Look at Pictures: We can look at all our favourite pictures and videos on our 
computer. 

 

 

Steps to Change Desktop Background: 

1. Right-click on the desktop: Click the right mouse buƩon anywhere on the 
desktop. 



2. Select "Change Desktop Background": A menu will appear. Click on "Change 
Desktop Background". 

3. Choose a new background: A window will open showing different background 
opƟons. You can choose from: 

    - Wallpapers: Pre-installed background images. 

    - Pictures: Your own pictures stored on the computer. 

 

 

Steps to Close the Computer System: 

1. Save your work: Make sure to save any open documents, pictures, or projects. 

2. Close all applicaƟons: Click the "X" buƩon on each applicaƟon window to close 
them. 

3. Click the Ubuntu logo: Click the Ubuntu logo (or your computer's logo) at the 
top leŌ corner of the screen. 

4. Select "Shut Down": A menu will appear. Click on "Shut Down" or "Power Off". 

 

AcƟvity 



1. Draw a simple diagram of Ubuntu Desktop and label its different components, 
such as the Desktop, Icons, and Toolbar. 

2. Write a short paragraph about your favourite thing to do on Ubuntu Desktop. 

 

 

Exercise – chapter 3 

 
MulƟple Choice QuesƟons 

1. What is the main area on Ubuntu Desktop where we can see our files and 
folders? 

a) Toolbar 

b) Desktop 

c) Icons 

d) Files and Folders 

Answer: b) Desktop 

 

2. What are the liƩle pictures on Ubuntu Desktop that help us open different 
programs? 

a) Icons 

b) Toolbars 

c) Files and Folders 

d) Desktop 

Answer: a) Icons 



 

3. What is the bar at the top of our screen that shows us important informaƟon? 

a) Toolbar 

b) Desktop 

c) Icons 

d) Files and Folders 

Answer: a) Toolbar 

4. What do you need to do to change the desktop background? 

a) Right-click on the desktop 

b) LeŌ-click on the desktop 

c) Double-click on the desktop 

d) None of the above 

 

Answer: a) Right-click on the desktop 

 

5. Where can you find the "Change Desktop Background" opƟon? 

a) In the Start menu 

b) In the Seƫngs menu 

c) By right-clicking on the desktop 

d) None of the above 

Answer: c) By right-clicking on the desktop 

 

6. What do you need to do before shuƫng down the computer? 



a) Save your work 

b) Close all applicaƟons 

c) Both a and b 

d) None of the above 

 

Answer: c) Both a and b 

 

7. Where can you find the "Shut Down" opƟon? 

a) In the Start menu 

b) In the Seƫngs menu 

c) By clicking the Ubuntu logo 

d) None of the above 

 

Answer: c) By clicking the Ubuntu logo 

 

Fill in the blanks: 

(Desktop, Linux Torvalds and 1991, open source, icons, toolbar, right click, 
seƫngs, save, Ubuntu) 

 1. Linux is an _______________________ operaƟng system. 

 2.  Linux was created by _______________________ in 
_______________________. 

 3. The _______________________ is the main area on Ubuntu Desktop where 
we can see  

       our files and folders. 



4. The liƩle pictures on Ubuntu Desktop that help us open different programs are 
called  

        _______________________. 

5. The _______________________ is the bar at the top of our screen that shows 
us  

    important informaƟon. 

6.  To change the desktop background, you need to _______________________ 
on the    

     desktop. 

7. The "Change Desktop Background" opƟon is available in the 
_______________________        

      menu. 

8.  Before shuƫng down the computer, you need to _______________________ 
your work. 

9. The "Shut Down" opƟon is available by clicking the _______________________ 
logo. 

True or False 

1. Ubuntu Desktop is a type of computer hardware. (False) 

2. The Ubuntu Desktop icons help us open different programs. (True) 

3. The Toolbar is located at the boƩom of our screen. (False) 

 

Short Answer QuesƟons 

1. What is Ubuntu Desktop? 

(Answer should include a brief descripƟon of Ubuntu Desktop as a computer 
program that helps us use our computer.) 



 

2. What can we use the Ubuntu Desktop icons for? 

(Answer should include a brief descripƟon of using icons to open different 
programs, such as games or painƟng tools.) 

3. What is the first step to change the desktop background? 

(Answer should include "Right-click on the desktop") 

4. What are the different opƟons available for changing the desktop background? 

(Answer should include "Wallpapers", "Pictures", etc.) 

5.  What is the importance of saving your work before shuƫng down the 
computer? 

(Answer should include "to prevent loss of data") 

6. What happens when you shut down the computer properly? 

(Answer should include "it helps keep the computer running smoothly") 

7.  What is the main difference between Linux and other operaƟng systems? 

8. Who created Linux and when? 

9. What are some of the key features of Linux? 

 

AcƟvity 

1. Draw a simple diagram of Ubuntu Desktop and label its different components, 
such as the Desktop, Icons, and Toolbar. 

2. Write a short paragraph about your favourite thing to do on Ubuntu Desktop. 

 

*************** 

  



 

CHAPTER 4 : 

INTRODUCTION TO LIBRE OFFICE WRITER 

 

LibreOffice Writer is a word processing software that allows us to create, edit, and 
print documents. It's like a digital notebook where we can write stories, create 
reports, and make lists. 

 

Uses of LibreOffice Writer 

1. Writing Stories: We can use LibreOffice Writer to write stories, poems, and even 
create our own books! 

2. Creating Reports: We can use LibreOffice Writer to create reports about our 
favorite animals, countries, or historical events. 

3. Making Lists: We can use LibreOffice Writer to make lists of our favorite foods, 
games, or movies. 

4. Designing Posters: We can use LibreOffice Writer to design posters for school 
events, campaigns, or awareness programs. 

5. Creating Letters: We can use LibreOffice Writer to write letters to our friends, 
family, or even our favorite authors! 

 

Components of the LibreOffice Writer  

 

Title Bar 

- Displays the name of the document and the LibreOffice Writer logo. 

Menu Bar 



- Contains menus like "File", "Edit", "View", and "Help" that provide options for 
working with documents. 

Toolbar 

- Provides quick access to frequently used tools like "New", "Open", "Save", and 
"Print". 

Ruler 

- Helps measure and align text and objects on the page. 

 

Document Area 

- Where you type and edit your document. 

 

Status Bar 

- Displays information about the document, such as page numbers and word count. 

 

Scroll Bars 

- Allow you to scroll up and down or left and right to view different parts of your 
document. 

 

 

Some key icons on the Toolbar: 

- New: Creates a new document. 

 

- Open: Opens an existing document. 

 

- Save: Saves your document. 



 

- Print: Prints your document. 

 

- Undo: Undoes your last action. 

 

- Redo: Redoes your last undone action. 

 

 

 

Working with Libre Office Writer  

steps for opening, creating, saving, opening, printing, and closing LibreOffice 
Writer-  

 Opening LibreOffice Writer 



1. Click on the LibreOffice Writer icon on the computer desktop or in the 
applications menu. 

2. Wait for the program to open. 

3. You will see the LibreOffice Writer window with a blank page. 

 

 Creating a Document 

1. Type a title for your document in the top line. 

2. Start typing your text below the title. 

3. Use the Enter key to start a new line. 

4. Use the Space bar to separate words. 

 

 Saving a Document 

1. Click on the File menu at the top left corner of the window. 

2. Select Save from the drop-down menu. 

3. Choose a location to save your document, such as the Documents folder. 

4. Type a name for your document in the File name box. 

5. Click Save. 

 

 Opening a Document 

1. Click on the File menu at the top left corner of the window. 

2. Select Open from the drop-down menu. 

3. Navigate to the location where you saved your document. 

4. Click on the document name to select it. 

5. Click Open. 

 



 Printing a Document 

1. Click on the File menu at the top left corner of the window. 

2. Select Print from the drop-down menu. 

3. Choose the printer you want to use. 

4. Select the number of copies you want to print. 

5. Click Print. 

 

 Closing LibreOffice Writer 

1. Click on the File menu at the top left corner of the window. 

2. Select Exit from the drop-down menu. 

3. If you have unsaved work, you will be asked if you want to save it. 

4. Click Yes to save your work or no to discard it. 

5. LibreOffice Writer will close. 

 

************* 

Exercise – lesson 4 

 

1. Multiple Choice Questions 

1. What is LibreOffice Writer? 

a) A painting software 

b) A word processing software 

c) A game software 

d) A video editing software 

Answer: b) A word processing software 



 

2. What can we use LibreOffice Writer for? 

a) Only for writing stories 

b) Only for creating reports 

c) For writing stories, creating reports, making lists, and more 

d) None of the above 

Answer: c) For writing stories, creating reports, making lists, and more 

 

3. What is the purpose of the spell check feature in LibreOffice Writer? 

a) To change the font size 

b) To insert images 

c) To correct spelling mistakes 

d) To create tables 

Answer: c) To correct spelling mistakes 

 

4. How do you open LibreOffice Writer? 

a) Click on the LibreOffice Writer icon on the desktop 

b) Click on the Start menu and select LibreOffice Writer 

c) Type "LibreOffice Writer" in the search bar 

d) All of the above 

Answer: d) All of the above 

 

5. What do you need to do to save a document in LibreOffice Writer? 

a) Click on the File menu and select Save 



b) Click on the Edit menu and select Save 

c) Click on the View menu and select Save 

d) None of the above 

Answer: a) Click on the File menu and select Save 

 

6. How do you print a document in LibreOffice Writer? 

a) Click on the File menu and select Print 

b) Click on the Edit menu and select Print 

c) Click on the View menu and select Print 

d) None of the above 

Answer: a) Click on the File menu and select Print 

 

2. Short Answer Questions 

1. What is LibreOffice Writer, and what can we use it for? 

(Answer should include a brief description of LibreOffice Writer as a word 
processing software and its various uses.) 

 

2. What are some of the basic features of LibreOffice Writer? 

(Answer should include text editing, image insertion, tables and charts, and spell 
check.) 

3. What are the steps to create a new document in LibreOffice Writer? 

(Answer should include typing a title, typing text, using the Enter key, and using the 
Space bar.) 

 



4. What happens when you click on the File menu and select Exit in LibreOffice 
Writer? 

(Answer should include that LibreOffice Writer will close and that you will be asked 
if you want to save any unsaved work.) 

 

 

3. Fill in the Blanks 

Word processing, stories, file, file,  

1. LibreOffice Writer is a _______________________ software that allows us to 
create, edit, and print documents. 

2. We can use LibreOffice Writer to write _______________________, create 
reports, and make lists. 

3. To open a document in LibreOffice Writer, you need to click on the 
_______________________ menu and select Open. 

4. To print a document in LibreOffice Writer, you need to click on the 
_______________________ menu and select Print. 

 

4. True or False 

1. LibreOffice Writer is a free software. (True) 

2. LibreOffice Writer can only be used for writing stories. (False) 

3. LibreOffice Writer has a built-in spell check feature. (True) 

4.LibreOffice Writer is a word processing software. (True) 

5. You can only save documents in LibreOffice Writer, not open them. (False) 

6. LibreOffice Writer has a built-in spell check feature. (True) 

 

Activity 



1. Create a new document in LibreOffice Writer and write a short story about your 
favorite animal. 

2. Create a list of your favorite foods and drinks using LibreOffice Writer. 

3. Design a poster for a school event using LibreOffice Writer. 

4. Open LibreOffice Writer and create a new document. 

5. Type a short story or poem and save it with a filename of your choice. 

6. Open the document you just saved and make some changes to it. 

7. Print the document using the Print option in the File menu. 

8. Close LibreOffice Writer and reopen it to make sure your document is saved. 

 

Points to Ponder – Shortcut Keys  

Navigation 

1. Ctrl + Home: Go to the beginning of the document 

2. Ctrl + End: Go to the end of the document 

3. Ctrl + Left/Right Arrow: Move cursor one word left/right 

4. Ctrl + Up/Down Arrow: Move cursor one paragraph up/down 

 

Editing 

1. Ctrl + C: Copy selected text 

2. Ctrl + X: Cut selected text 

3. Ctrl + V: Paste copied/cut text 

4. Ctrl + Z: Undo last action 

5. Ctrl + Y: Redo last undone action 

 

Formatting 



1. Ctrl + B: Bold selected text 

2. Ctrl + I: Italicize selected text 

3. Ctrl + U: Underline selected text 

 

Saving and Printing 

1. Ctrl + S: Save document 

2. Ctrl + P: Print document 

 

Other 

1. F1: Open Help menu 

2. Ctrl + N: New document 

3. Ctrl + O: Open document 

 

  



 

CHAPTER 5 

Introduction to Tux Paint 

 

What is Tux Paint? 

Tux Paint is a free and fun painting software that allows us to create and edit pictures 
using our computer. 

Features of Tux Paint 

1. Easy to use: Tux Paint has a simple and intuitive interface that makes it easy for 
kids to use. 

2. Variety of tools: Tux Paint offers a range of painting tools, including brushes, 
shapes, and stamps. 

3. Colorful palette: Tux Paint has a wide range of colors to choose from, making it 
perfect for creating bright and colorful artwork. 

4. Undo and redo: Tux Paint allows us to undo and redo our actions, making it easy 
to experiment and try new things. 

 

Uses of Tux Paint 

1. Creating artwork: Tux Paint is perfect for creating artwork, such as paintings, 
drawings, and collages. 

2. Designing cards and posters: Tux Paint can be used to design cards and posters 
for special occasions. 

3. Illustrating stories: Tux Paint can be used to illustrate stories and create comics. 

4. Having fun: Most importantly, Tux Paint is a fun and creative way to express 
ourselves and explore our imagination! 



 

 

 

 

Basic Components of Tux Paint 

1. Toolbar: The toolbar provides access to Tux Paint's various tools and features. 

2. Canvas: The canvas is the area where we create our artwork. 

3. Color palette: The color palette allows us to choose from a range of colors. 

4. Undo and redo buttons: The undo and redo buttons allow us to undo and redo our 
actions. 

 

 

Tools in Tux Paint  

Drawing Tools 

1. Brush: Use the brush tool to paint and draw on the canvas. 

2. Eraser: Use the eraser tool to remove mistakes or unwanted parts of your artwork. 



3. Line: Use the line tool to draw straight lines. 

4. Shape: Use the shape tool to draw shapes like squares, circles, and triangles. 

 

Color Tools 

1. Color Palette: Choose from a variety of colors to use in your artwork. 

2. Fill: Use the fill tool to fill a shape or area with a color. 

 

Stamp Tools 

Stamp: Use the stamp tool to add fun images like animals, shapes, and symbols to 
your artwork. 

 

Text Tools 

 Text: Use the text tool to add words or sentences to your artwork. 

 

Other Tools 

1. Undo: Use the undo tool to go back to a previous version of your artwork. 

2. Redo: Use the redo tool to go forward to a newer version of your artwork. 

3. Save: Use the save tool to save your artwork with a filename of your choice. 

 

Fill effect in the Magic tool in Tux Paint 

Fill Effect 

The Fill effect in the Magic tool is used to fill a closed shape or area with a color or 
pattern. 

 

How to use the Fill effect: 



1. Select the Magic tool from the toolbar. 

2. Choose the Fill effect from the Magic tool menu. 

3. Select the color or pattern you want to use to fill the shape or area. 

4. Click on the shape or area you want to fill. 

 

Smudge Effect 

The Smudge effect in Tux Paint is used to smudge or blur colors together. 

How to use the Smudge effect: 

1. Select the Magic tool from the toolbar. 

2. Choose the Smudge effect from the Magic tool menu. 

3. Select the brush size and shape you want to use. 

4. Click and drag on the artwork to smudge the colors. 

 

Real Rainbow Effect 

The Real Rainbow effect in Tux Paint is used to create a realistic rainbow effect. 

 

How to use the Real Rainbow effect: 

1. Select the Magic tool from the toolbar. 

2. Choose the Real Rainbow effect from the Magic tool menu. 

3. Select the size and shape of the rainbow you want to create. 

4. Click on the artwork to add the rainbow. 

 

Foam Effect 

The Foam effect in Tux Paint is used to create a foamy, bubbly texture. 



 

How to use the Foam effect: 

1. Select the Magic tool from the toolbar. 

2. Choose the Foam effect from the Magic tool menu. 

3. Select the brush size and shape you want to use. 

4. Click and drag on the artwork to add the foam effect. 

Mosaic Effect 

The Mosaic effect in Tux Paint is used to create a mosaic, tile-like effect. 

How to use the Mosaic effect: 

1. Select the Magic tool from the toolbar. 

2. Choose the Mosaic effect from the Magic tool menu. 

3. Select the tile size and shape you want to use. 

4. Click on the artwork to add the mosaic effect. 

 

Undo and Redo tools in Tux Paint 

 Undo Tool 

The Undo tool is used to go back to a previous version of your artwork. 

 

How to use the Undo tool: 

1. Click on the "Undo" button in the toolbar. 

2. Your artwork will go back to its previous state. 

 

Why use the Undo tool? 

1. To correct mistakes. 



2. To try again if you don't like what you've done. 

 

 

 Redo Tool 

The Redo tool is used to go forward to a newer version of your artwork. 

 

How to use the Redo tool: 

1. Click on the "Redo" button in the toolbar. 

2. Your artwork will go forward to its newer state. 

 

Why use the Redo tool? 

1. To restore changes, you made after using the Undo tool. 

2. To continue working on your artwork after correcting mistakes. 

 

Creating a Slideshow in Tux Paint 



Step 1: Create Your Slides 

1. Open Tux Paint and create a new picture. 

2. Draw or paint something on the picture. 

3. Save the picture with a name, like "slide1". 

Step 2: Create More Slides 

1. Repeat steps 1-3 to create more pictures (slides). 

2. Save each picture with a different name, like "slide2", "slide3", etc. 

 

Step 3: Create a Slideshow 

1. Go to the "File" menu and select "Slideshow". 

2. Choose the pictures (slides) you want to include in your slideshow. 

3. Click "OK" to create the slideshow. 

Step 4: View Your Slideshow 

1. Click on the "Play" button to start the slideshow. 

2. Watch your slides appear one after the other. 

*************** 

 

  



Exercise – lesson 3  

Multiple Choice Questions 

1. What is Tux Paint? 

a) A word processing software 

b) A painting software 

c) A game software 

d) A video editing software 

Answer: b) A painting software 

 

2. What is the purpose of the toolbar in Tux Paint? 

a) To choose colors 

b) To undo and redo actions 

c) To access tools and features 

d) To save artwork 

Answer: c) To access tools and features 

 

3. What is the canvas in Tux Paint? 

a) The area where we choose colors 

b) The area where we access tools and features 

c) The area where we create our artwork 

d) The area where we save our artwork 

Answer: c) The area where we create our artwork 

 

4. What is the tool used to paint and draw on the canvas? 



a) Eraser 

b) Brush 

c) Line 

d) Shape 

Answer: b) Brush 

 

5. Which tool is used to remove mistakes or unwanted parts of your artwork? 

a) Brush 

b) Eraser 

c) Fill 

d) Text 

Answer: b) Eraser 

 

6. What is the tool used to add fun images like animals, shapes, and symbols to your 
artwork? 

a) Brush 

b) Eraser 

c) Stamp 

d) Fill 

Answer: c) Stamp 

 

7. What is the purpose of the Smudge effect in the Magic tool? 

a) To create a foamy texture 

b) To blur colors together 

c) To fill a shape with color 



d) To create a mosaic effect 

Answer: b) To blur colors together 

 

8. Which effect is used to create a realistic rainbow? 

a) Real Rainbow 

b) Foam 

c) Mosaic 

d) Smudge 

Answer: a) Real Rainbow 

 

9. What does the Smudge effect do in Tux Paint? 

a) Creates a rainbow 

b) Fills a shape with color 

c) Blurs colors together 

d) Creates a mosaic effect 

Answer: c) Blurs colors together 

 

10. Which effect creates a realistic rainbow in Tux Paint? 

a) Smudge 

b) Foam 

c) Mosaic 

d) Real Rainbow 

Answer: d) Real Rainbow 

 



 

11. What does the Foam effect do in Tux Paint? 

a) Creates a mosaic effect 

b) Fills a shape with color 

c) Creates a foamy texture 

d) Blurs colors together 

Answer: c) Creates a foamy texture 

 

12. What does the Mosaic effect do in Tux Paint? 

a) Creates a foamy texture 

b) Fills a shape with color 

c) Creates a mosaic, tile-like effect 

d) Blurs colors together 

Answer: c) Creates a mosaic, tile-like effect 

 

13. What does the Undo tool do in Tux Paint? 

a) Deletes the entire picture 

b) Goes back to a previous version of the picture 

c) Saves the picture 

d) Prints the picture 

Answer: b) Goes back to a previous version of the picture 

 

14. What does the Redo tool do in Tux Paint? 

a) Goes back to a previous version of the picture 



b) Goes forward to a newer version of the picture 

c) Deletes the entire picture 

d) Saves the picture 

Answer: b) Goes forward to a newer version of the picture 

15. What is a slideshow in Tux Paint? 

a) A single picture 

b) A collection of pictures shown one after the other 

c) A video 

d) A game 

Answer: b) A collection of pictures shown one after the other 

 

16. How do you create a slideshow in Tux Paint? 

a) By clicking on the "Slideshow" button 

b) By selecting "File" > "Slideshow" 

c) By clicking on the "New" button 

d) By selecting "Edit" > "Slideshow" 

Answer: b) By selecting "File" > "Slideshow" 

 

Short Answer Questions 

1. What are some of the features of Tux Paint? 

(Answer should include easy-to-use interface, variety of tools, colorful palette, and 
undo and redo features.) 

 

2. What are some of the uses of Tux Paint? 



(Answer should include creating artwork, designing cards and posters, illustrating 
stories, and having fun.) 

 

3. What is the purpose of the color palette in Tux Paint? 

(Answer should include choosing colors for artwork.) 

 

4. What is the difference between the undo and redo tools in Tux Paint? 

(Answer should include going back to a previous version and going forward to a 
newer version of artwork.) 

 

5. What is the difference between the Fill and Mosaic effects in the Magic tool? 

(Answer should include that Fill fills a shape with a solid color or pattern, while 
Mosaic creates a tile-like effect.) 

 

6. How do you use the Smudge effect in the Magic tool? 

(Answer should include selecting the Smudge effect, choosing a brush size and 
shape, and clicking and dragging on the artwork.) 

 

7. How do you use the Smudge effect in Tux Paint? 

(Answer should include selecting the Smudge effect, choosing a brush size and 
shape, and clicking and dragging on the artwork.) 

 

8. What is the difference between the Foam and Mosaic effects in Tux Paint? 

(Answer should include that Foam creates a foamy texture, while Mosaic creates a 
tile-like effect.) 

 



9. Why is the Undo tool useful in Tux Paint? 

(Answer should include correcting mistakes or trying again.) 

 

10. How does the Redo tool work in Tux Paint? 

(Answer should include going forward to a newer version of the picture after using 
the Undo tool.) 

 

11. What are the steps to create a slideshow in Tux Paint? 

(Answer should include: create multiple pictures, select "File" > "Slideshow", 
choose the pictures to include, and click "OK".) 

 

12. What is the purpose of the slideshow feature in Tux Paint? 

(Answer should include: to display multiple pictures in a sequence, to create a 
presentation, or to tell a story.) 

 

True or False 

1. Tux Paint is a word processing software. (False) 

2. Tux Paint has a wide range of colors to choose from. (True) 

3. Tux Paint allows us to undo and redo our actions. (True) 

4.The stamp tool is used to add text to your artwork. (False) 

5. The fill tool is used to fill a shape or area with a color. (True) 

6. The undo tool is used to go forward to a newer version of your artwork. (False) 

7. The Undo tool deletes the entire picture. (False) 

8. The Redo tool goes back to a previous version of the picture. (False) 



9. The Undo and Redo tools are useful for correcting mistakes and trying again. 
(True) 

10. A slideshow in Tux Paint can only include one picture. (False) 

11. To create a slideshow in Tux Paint, you need to select "Edit" > "Slideshow". 
(False) 

12. A slideshow in Tux Paint is a collection of pictures shown one after the other. 
(True) 

 

Fill in the Blanks 

Painting, toolbar, bush, eraser, real rainbow, smudge, foam, mosaic, undo, redo, 
file, pictures. 

1. Tux Paint is a free and fun _______________________ software. 

2. The _______________________ provides access to Tux Paint's various tools and 
features. 

3. The _______________________ tool is used to paint and draw on the canvas. 

4. The _______________________ tool is used to remove mistakes or unwanted 
parts of your artwork. 

5. The _______________________ effect in Tux Paint creates a realistic rainbow. 

6. The _______________________ effect in Tux Paint blurs colors together. 

7. The _______________________ effect in Tux Paint creates a foamy texture. 

8. The _______________________ effect in Tux Paint creates a mosaic, tile-like 
effect. 

 

9. The _______________________ tool is used to go back to a previous version of 
the picture. 

 



10. The _______________________ tool is used to go forward to a newer version 
of the picture. 

 

11. To create a slideshow in Tux Paint, you need to select 
_______________________ > "Slideshow". 

 

12. A slideshow in Tux Paint is a collection of _______________________ shown 
one after the other. 

 

Activity 

1.  Create a new artwork using Tux Paint and save it with a filename of your choice. 

2.  Open Tux Paint and practice using the different effects in the Magic tool, such as 
Fill, Foam, Mosaic, Smudge, and Real Rainbow. 

3.  Open Tux Paint and create 3-5 new pictures.  Select "File" > "Slideshow" to create 
a slideshow.  Choose the pictures to include in the slideshow and click "OK".  View 
your slideshow and make any necessary adjustments. 

 

 

 

 

  



 

CHAPTER – 6 

AI – ENABLED DEVICES 

 What is ArƟficial Intelligence (AI)? 

ArƟficial Intelligence is like a super smart computer that can think and 
learn like humans. Just like how you can teach a dog new tricks, we can 
teach computers to do new things using AI. 

 

 How is AI used in our daily life? 

1. Virtual Assistants: You might have seen your parents using virtual 
assistants like Siri, Google Assistant, or Alexa. These assistants use AI to 
understand our voice commands and do tasks for us. 

2. Image RecogniƟon: Have you ever taken a selfie and the phone 
recognizes your face? That's AI at work! It helps the phone idenƟfy 
people, objects, and even emoƟons in pictures. 

3. Games: Many games use AI to make the game more challenging and 
fun. For example, in a car racing game, the AI can make the opponent 
cars drive more realisƟcally. 

4. Chatbots: You might have interacted with chatbots on websites or 
apps. These chatbots use AI to understand our quesƟons and give us 
answers. 

5. Self-Driving Cars: Some cars are being designed to drive themselves 
using AI. They can recognize roads, traffic lights, and even pedestrians! 



6. Smart Homes: Some homes have smart devices that can control the 
temperature, lighƟng, and security using AI. 

 smartphone is a special kind of phone 
that can do many things besides making 
calls and sending messages. It's like a 
small computer that you can carry with 
you everywhere! You can play lots of fun 
games on a smartphone. You can watch 
your favorite cartoons, movies, and videos 
on a smartphone. You can take pictures 
using a smartphone. You can listen to your 

favorite songs and music also. You can use a smartphone to access the 
internet and learn new things. 

 smart doorbell is a special kind of doorbell 
that can see, hear, and talk to people who 
come to your door. It's like having a magic 
eye that helps keep your home safe. A 
smart doorbell has a camera that can show 
you who's at the door, even if you're not at 
home. You can talk to people at the door 
using your smartphone or tablet, even if 

you're not at home. A smart doorbell can record videos of people who 
come to your door, so you can see what happened even if you're not 
there. If someone comes to your door, a smart doorbell can send a 
message to your smartphone or tablet, so you know someone's there. 

A smart doorbell is a cool device that helps keep your home safe and 
makes it easy to answer the door, even if you're not at home. 



 

 

A Smart TV is a special kind of television that can 
connect to the internet and do many things besides 
just showing TV channels. It's like having a big 
computer screen in your living room!You can watch 

your favorite TV shows, movies, and cartoons on a Smart TV. You can 
play games on a Smart TV, just like on a computer or gaming console. 
You can use a Smart TV to browse the internet, just like on a computer 
or tablet. You can watch your favorite YouTube videos on a Smart TV. 
You can connect your smartphone, tablet, or computer to a Smart TV 
and share pictures, videos, and music. 

 

A driverless car, also called a self-
driving car, is a special kind of car that 
can drive itself without a human 
driver. It's like having a personal 
chauffeur, but instead of a person, it's 
a computer that drives the car! A 

driverless car has special sensors and cameras that help it see the road 
and detect other cars, people, and objects. The car has a powerful 
computer brain that uses the informaƟon from the sensors and cameras 
to make decisions about how to drive. The car uses GPS and maps to 
navigate and find its way. Driverless cars can help reduce accidents 
caused by human error. 

 Conclusion 



In this chapter, we explored some amazing smart technologies that are 
changing our world. We learned about smartphones, smart doorbells, 
smart TVs, and even driverless cars! These technologies are not only 
making our lives easier and more convenient, but they're also helping 
us stay safe and connected. As we conƟnue to learn and grow, 
remember to always be curious, keep exploring, and stay excited about 
the amazing possibiliƟes that technology has to offer. 

 

 

  



 

CHAPTER – 7 

AI – ENABLED DEVICES 
  

 

BOOK EXERCISES 

A. Answer the following quesƟons in short.  

Q1. What is the full form of AI? 

Ans – The full form of AI is ArƟficial Intelligence. 

Q2. Name some popular AI devices. 

Ans – Some popular AI devices are smartphones, smartwatches, smart 
doorbells, smart T.V, driverless cars, etc.  

Answer the following quesƟons in detail.  

Q1. What is a smartphone, and what are some of its main funcƟons? 

 Ans- A smartphone is a special kind of phone that can connect to the internet 
and do many things besides just making calls and sending messages. Some of 
its main funcƟons include making calls, sending messages, browsing the 
internet, taking pictures, and playing games. 

Q2. What is a smart doorbell, and how does it work? 

Ans - A smart doorbell is a special kind of doorbell that can see, hear, and talk 
to people who come to your door. It works by using sensors and cameras to 
detect moƟon and record video, and it can alert the homeowner through a 
smartphone app. 

 

Q3. What is a driverless car, and what are some of its benefits? 



Ans - A driverless car is a special kind of car that can drive itself without a 
human driver. Some of its benefits include safer roads, more free Ɵme for 
passengers, and help for people with disabiliƟes who may not be able to drive 
themselves. 

B.  Fill in the blank  
(Internet, moƟon sensor, GPS, Internet, think) 

 1.A smartphone is a special kind of phone that can connect to the _________. 

2. A smart doorbell has a special feature called _______ that allows it to detect 
moƟon. 

3. A driverless car uses ______ to navigate and find its way. 

4. A Smart TV can connect to the _________ to stream videos and play games. 

5. ArƟficial Intelligence (AI) is a type of technology that allows computers to 
________ and      learn like humans. 

 

C.  MulƟple choice quesƟons. 
1. What is the main funcƟon of a smartphone? 

A) Only making calls 

B) Only sending messages 

C) ConnecƟng to the internet and doing many things 

D) Only playing games 

 Correct Answer: C) ConnecƟng to the internet and doing many things 

2. What is a smart doorbell equipped with? 

A) Only a camera 

B) Only a moƟon sensor 

C) Both a camera and a moƟon sensor 



D) Neither a camera nor a moƟon sensor 

 Correct Answer: C) Both a camera and a moƟon sensor 

3. What technology is used in driverless cars to navigate? 

A) GPS 

B) Internet 

C) ArƟficial Intelligence 

D) All of the above 

Correct Answer: D) All of the above 

4. What can you do on a Smart TV? 

A) Only watch TV shows 

B) Only play games 

C) Stream videos, play games, and browse the internet 

D) None of the above 

Correct Answer: C) Stream videos, play games, and browse the internet 

5. What is ArƟficial Intelligence (AI)? 

A) A type of computer hardware 

B) A type of computer soŌware 

C) A type of technology that allows computers to think and learn like humans 

D) None of these 

Correct Answer: C) A type of technology that allows computers to think and 
learn like humans 

D. State True or False. 
1. A smartphone can only make calls and send messages. (F) 
2. A smart doorbell has a moƟon sensor that can detect movement. (T) 
3. Driverless cars use GPS to navigate and find their way. (T) 



4. A Smart TV can only watch TV shows. (F) 
5.  ArƟficial Intelligence (AI) is a type of technology that allows computers to 
think and learn like humans. (T) 

 

 

 

 

 

 

 

 

 

 

 

 

  



 

 

CHAPTER 7 

STEPWISE - THINKING 

Do you know how computers solve problems? They follow a special set 
of instrucƟons, one step at a Ɵme! This is called stepwise thinking. 

Why is Stepwise Thinking Important? 

Stepwise thinking is essenƟal for problem-solving in computer science 
because it helps us: 

- Break down complex problems into smaller parts 

- IdenƟfy the steps needed to solve each part 

- Write clear and precise instrucƟons (algorithms) to solve the problem 

- Avoid mistakes and errors by following each step carefully 

 Real-Life Examples of Stepwise Thinking 

You might be surprised to know that stepwise thinking is used in many 
real-life situaƟons, such as: 

-  Following a recipe to cook a meal 

- Assembling a piece of furniture using instrucƟons 

- Solving a puzzle or playing a game that requires strategic thinking 

Here are some examples to explain the concept of stepwise thinking: 

Example 1: Making a Peanut BuƩer and Jelly Sandwich 

1. Get two slices of bread. 



2. Open the peanut buƩer jar. 

3. Spread peanut buƩer on one slice of bread. 

4. Open the jelly jar. 

5. Spread jelly on the other slice of bread. 

6. Put the two slices of bread together. 

 

 Example 2: Brushing Your Teeth 

1. Get your toothbrush. 

2. Squeeze toothpaste on the toothbrush. 

3. Brush your teeth in circular moƟons. 

4. Brush your tongue and the roof of your mouth. 

5. Spit out the toothpaste. 

6. Rinse your mouth with water. 

 

These examples illustrate how stepwise thinking can be applied to 
various everyday tasks, problems, and acƟviƟes. By breaking down 
complex tasks into smaller, manageable steps, we can achieve our goals 
more efficiently and effecƟvely. 

 What is a Loop? 

A loop is a programming concept that allows a set of instrucƟons to be 
repeated over and over again. It's like a merry-go-round that keeps 
going around in a circle unƟl it's told to stop! Loops are useful when we 
need to perform a task mulƟple Ɵmes.  



importance of problem-solving and stepwise thinking: 

Problem-solving and stepwise thinking are essenƟal skills that help us 
navigate the complexiƟes of life. By developing these skills, we can 
improve our criƟcal thinking, analyƟcal skills, and producƟvity. 

It is a systemaƟc process that requires analyzing the problem, 
generaƟng soluƟons, evaluaƟng the opƟons, and implemenƟng the best 
soluƟon. Problem-solving is essenƟal in real-life situaƟons as it helps 
individuals to navigate through complex challenges, make informed 
decisions, and achieve their objecƟves. It is a valuable skill that is 
required in various aspects of life, including academics, career, and 
personal relaƟonships. 

 

CHAPTER 7 

STEPWISE – THINKING 

Book Exercises 

A. Fill in the blank. 
(ComplexiƟes, steps, condiƟon, decisions, stepwise)  

1. Problem-solving is a criƟcal skill that helps us navigate the 
________ of life. 

2. Stepwise thinking is a systemaƟc approach to problem-solving 
that helps us break down complex problems into manageable 
_________. 

3. A loop is a programming concept that allows a set of instrucƟons 
to be repeated over and over again unƟl a certain ________ is 
met. 



4. CriƟcal thinking is an essenƟal skill for problem-solving that helps 
us analyze situaƟons, idenƟfy soluƟons, and make informed 
_______. 

5. Algorithms are a set of instrucƟons that are used to solve a 
problem in a _______ and efficient manner. 

 

B. State true and false . 
1.  Problem-solving is only used in academics.(F) 
2.  Stepwise thinking involves breaking down complex problems into 

manageable steps.(T) 
3.  Loops are used to repeat a set of instrucƟons only once. (F) 
4. CriƟcal thinking is not essenƟal for problem-solving. (F) 
5. Algorithms are a set of instrucƟons that are used to solve a 

problem in a random manner. (F) 

 

C.  MulƟple-choice quesƟons . 
1. What is problem-solving? 

A) A skill used only in academics 

B) A criƟcal skill used in various aspects of life 

C) A skill used only in programming 

D) A skill used only in mathemaƟcs 

Correct Answer: B) A criƟcal skill used in various aspects of life 

2. What is stepwise thinking? 

A) A systemaƟc approach to problem-solving that involves breaking 
down complex problems into manageable steps 



B) A random approach to problem-solving 

C) A trial-and-error approach to problem-solving 

D) A intuiƟve approach to problem-solving 

 Correct Answer: A) A systemaƟc approach to problem-solving that 
involves breaking down complex problems into manageable steps 

3. What is a loop? 

A) A programming concept that allows a set of instrucƟons to be 
repeated only once 

B) A programming concept that allows a set of instrucƟons to be 
repeated mulƟple Ɵmes 

C) A programming concept that allows a set of instrucƟons to be 
skipped 

D) A programming concept that allows a set of instrucƟons to be 
reversed 

 Correct Answer: B) A programming concept that allows a set of 
instrucƟons to be repeated mulƟple Ɵmes 

4. What is criƟcal thinking? 

A) A skill that involves analyzing situaƟons, idenƟfying soluƟons, and 
making informed decisions 

B) A skill that involves making random decisions 

C) A skill that involves following instrucƟons blindly 

D) A skill that involves avoiding problems 



 Correct Answer: A) A skill that involves analyzing situaƟons, idenƟfying 
soluƟons, and making informed decisions 

 

5. What is an algorithm? 

A) A set of instrucƟons that are used to solve a problem in a random 
manner 

B) A set of instrucƟons that are used to solve a problem in a stepwise 
and efficient manner 

C) A set of instrucƟons that are used to solve a problem in a trial-and-
error manner 

D) A set of instrucƟons that are used to solve a problem in an intuiƟve 
manner 

 Correct Answer: B) A set of instrucƟons that are used to solve a 
problem in a stepwise and efficient manner 

 

D. Give one word answer. 

1. Problem-solving - A criƟcal skill used in various aspects of life 

2. Stepwise thinking - A systemaƟc approach to breaking down complex 
problems 

3. Loop - A programming concept that repeats instrucƟons 

4. CriƟcal thinking - A skill that involves analyzing situaƟons and making 
informed decisions 



5. Algorithm - A set of instrucƟons that solves a problem in a stepwise 
manner 

 

 E. Short Answer QuesƟons: 

 Q1. What is problem-solving? 

Ans- Problem-solving is a criƟcal skill used to overcome obstacles and 
achieve goals. 

Q2. What is an algorithm? 

 Ans- An algorithm is a set of instrucƟons used to solve a problem in a 
stepwise manner. 

 

 F. Long Answer QuesƟons: 

Q1.Explain the concept of problem-solving and its importance in real-
life situaƟons. 

Ans - Problem-solving is a criƟcal skill that involves idenƟfying and 
overcoming obstacles to achieve a specific goal. It is a systemaƟc 
process that requires analyzing the problem, generaƟng soluƟons, 
evaluaƟng the opƟons, and implemenƟng the best soluƟon. Problem-
solving is essenƟal in real-life situaƟons as it helps individuals to 
navigate through complex challenges, make informed decisions, and 
achieve their objecƟves. It is a valuable skill that is required in various 
aspects of life, including academics, career, and personal relaƟonships. 

 



Q2. Describe the concept of stepwise thinking and its applicaƟon in 
computer programming. 

Ans - Stepwise thinking is a systemaƟc approach to problem-solving 
that involves breaking down complex problems into manageable steps. 
It is a logical and methodical process that requires analyzing the 
problem, idenƟfying the key steps, and implemenƟng the soluƟon in a 
sequenƟal manner. In computer programming, stepwise thinking is 
essenƟal for wriƟng algorithms, which are sets of instrucƟons that solve 
a specific problem. Programmers use stepwise thinking to break down 
complex problems into smaller, manageable parts, and then write code 
to implement the soluƟon. 

Q3. Explain the concept of algorithms and their role in computer 
programming. 

Ans - An algorithm is a set of instrucƟons that solves a specific problem 
in a stepwise manner. It is a well-defined procedure that takes some 
input, processes it, and produces a corresponding output. Algorithms 
are essenƟal in computer programming as they provide a systemaƟc 
approach to solving complex problems. They are used to perform 
various tasks, such as sorƟng data, searching for informaƟon, and 
solving mathemaƟcal equaƟons. Algorithms are wriƩen in a 
programming language and are executed by a computer to produce the 
desired output. 
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